problem with buttons

problem with buttons

Support Forums KingBlocks – WP Gutenberg Plugin problem with buttons

This topic contains 12 replies, has 2 voices, and was last updated by  CreaboxThemes 1 month, 4 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #6141

    Alice
    Participant

    I’m seeing odd behavior in the buttons on both Card Image and Card blocks. On Card Image, if I replace the default “Button” text, I see the text I replaced it with when in admin but in the page preview there’s just a B. That can’t be right. On the Card Blocks, if I replace the default text, I see the replacement text in admin but just a T in the page preview. Also, the button for Card Blocks goes off the right side of the Card Block. None of this can be right. Do you have a fix for these issues? Genesis child theme, Showcase.

    #6142

    CreaboxThemes
    Keymaster

    Hi Alice,

    sorry for the inconveniences. I have made tests with both blocks and they work fine with the last version 3.8.0 of Gutenberg plugin.

    Maybe it is an incompatibility with some plugin or the main theme. Could you create a new user for me in your admin panel? In that way, I can check the problems and try to resolve them. I have done this with other users, so you can trust me.

    Regards

    #6147

    Alice
    Participant

    Hi Keymaster,

    Thanks for the reply. I have no problem providing you with admin access. How should I do that? The response email came from noreply@creabox.es, so setting up the account with that email address won’t work. Please let me know on that, and I’ll take care of it.

    Thanks,

    Alice

    #6148

    Alice
    Participant

    No problem setting up admin access for you. How shall I do that? I don’t know if a reply here is public or not.

    Thanks,

    Alice

    #6150

    Alice
    Participant

    I went ahead and started troubleshooting. I deactivated all plugins except Gutenberg and King Blocks on the site I bought the plugin for. Got the same thing. Enter button text and it shows in admin (until I move away from the page) but it’s replaced with a B for Image Card and a T for Card (and that’s what it’s like if I leave the page in admin and go back).

    Next, I tried it on a staging domain of mine. Tried a vanilla install of the Genesis child theme instead of the modified theme running on the original site. Same result.

    Tried 2017 theme, in case it’s a Genesis thing. Same result.

    Any thoughts?

    #6152

    CreaboxThemes
    Keymaster

    Send me the access to admin@creabox.es please. I will check the problem.

    Regards

    #6156

    CreaboxThemes
    Keymaster

    Hi,

    I have accessed to your website and I have made test with both blocks, card block and card image block. I have changed the button text and it works fine. I have saved and change the text and it works fine. I have logged out and then access and change the text and it works fine.

    I don’t know how you got that problem.

    Regards

    #6157

    Alice
    Participant

    I can’t say that I know how I’m getting these problems, but I can say that I’m still getting them. Persistently and consistently in Firefox, Edge, and Chrome. With great persistence, I can somewhat get these to work in Edge, but there’s a problem with even entering text into the buttons in that one. It doesn’t want to go into the box when I type. I could live with that, I suppose. In all browsers, in all cases, the right edge of the button on the Card block still disappears. What browser and version were you using when you tested?

    The other thing I can say for sure is that these two block types do not work “fine.” Since I’ve already ruled out it being a problem with the theme, it can’t be that.

    #6158

    CreaboxThemes
    Keymaster

    Hi,

    I undertand you and I want to help you. But, if I can’t reproduce the same problems I can’t help. In your website, I have created you pages called ‘Card test’ and ‘Card image test’, and I was be able to change the texts of the buttons without problems.

    I use Chrome, Firefox and Edge. The versions are 68.0.3440.106, 62.0 and 42.17134.1.0 respectively.

    Regards

    #6159

    Alice
    Participant

    Yeah, I really, really understand about “if I can’t see it, I can’t fix it.” I’ve gone rounds with that for many years on customer sites where all they say is that something doesn’t work without being able to give any details. It’s something odd going on. I accessed your test pages in Firefox and changed the button text. Got the same bad result as I was getting. Switched over to Edge, where I was able to get the button text changes to stick (with a lot of effort). But in no case, your original test page included, does the card button display correctly. It always goes all the way over to the right side and gets chopped off. It does that in the basic 2017 theme with no other plugins running. On a different site of mine. I’ll remove your plugin from the second site, since I purchased a single license and only plan to use it on the original site. It’s not productive for either one of us to keep chasing this. There are a couple of other blocks in King Blocks that are useful to me, so I’ll just use the ones that work and not use the ones that don’t. Thanks for trying.

    #6160

    CreaboxThemes
    Keymaster

    I’m so sorry for the inconveniences. I have made a last test in your website and I have changed the texts to ‘read more and more’ without problems.
    Anyway, I will check these blocks more exhaustive way to try to find the problem.

    Regards

    #6161

    Alice
    Participant

    Don’t spend anymore time on this on my account if you don’t get any others having the same problem. You’ve gone the extra mile on this already, and I’m happy enough with the blocks in the plugin that work well for me. I can work around the rest of the items. I’m a big fan of the Divider Text block, and I’m already using that on my site. It’s all good. I’m not going away mad or anything like that.

    Best wishes,

    Alice

    #6162

    CreaboxThemes
    Keymaster

    Ok. Thank you very much.

    If you need something more, contact me please.

    Regards

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.